Testing needed: Out-of-the box MIDI support

Hi everyone !

Installing the requirements for MIDI support in Open Stage Control has always been a major difficulty for many users, especially Windows and Mac users. I’m considering packaging the midi extension with Open Stage Control to make it work out-the-box, but before that I need to make sure it actually works.

Supported platforms are

  • Linux 64bit
  • Windows 64bit
  • Mac OSX 64bit

Other systems (32bit systems, raspberries, etc) will still rely on the current installation process.

Testing is very simple

  • download and try Open Stage Control v1.7.0-beta3
  • make sure your midi config does not contain a path= parameter.
  • do some midi stuff, like listing midi devices, sending messages… :slight_smile:

This version comes with a built-in executable that will be used instead of your local version of python and python-rtmidi, it’s supposed to work when none of them are installed.

Let me know if it works :), otherwise please provide some details to help debugging: what’s your operating system, what’s the error, when does it happen, etc.

1 Like

That would be such a great improvement !!! :+1:

I spent sooooo much time trying to install python on windows and macOS just to have working MIDI in O-S-C :confounded:
(I finally managed to make it work… but it has been really a pain-in-the-* ! I don’t even remember all the steps I went through, all I can say is it was not straightforward at all )

I’ve just tested the executable on windows : works fine here (windows 10 64bits) :ok_hand:

On my Mac (macOs 10.15.7) I have this error message :

(ERROR, MIDI) spawn /Users/mathieuchamagne/Dropbox/OpenStageControl/osc-midi/osc-midi-osx EACCES

what does it mean ?

Thanks for testing :). The error on Mac is a permission error, you’ll need to mark it manually as an executable to make it work:

chmod u+x path/to/osc-midi-osx

Hopefully this shouldn’t be necessary when packaged in the distributed .app file.

Edit: the executables are now zipped and should come with the appropriate permissions.

I though it could be something like that… I did tried

xattr -d -r com.apple.quarantine /Users/mathieuchamagne/Dropbox/OpenStageControl/osc-midi

but it didn’t worked. (it’s the recipe I use to apply for unsigned Max externals …)

thanks

You are a blessing!

If I’m reading your post correctly, you are basically going to eliminate all the installation process?

OMG! I literally wanted to make a video to explain the installation for windows. I think I will test this first. After all, we want people to have a user-friendly experience instead of having difficulties and a bunch of tutorials explaining how to overcome challenges :slight_smile:

@jean-emmanuel is further testing on windows needed here, then i will try it too.

Yes please more tests :slight_smile:

Cool add-on

I have this error in the log after replacing my midi set up :
(ERROR, MIDI) Could not find python binary: path/to/osc-midi-you-extracted

edit I tried to reinstall and in fact I get this :
["log", "(ERROR, MIDI) Traceback (most recent call last):\n File \"midi.py\", line 244, in <module>\n File \"json/__init__.py\", line 348, in loads\n File \"json/decoder.py\", line 337, in decode\n File \"json/decoder.py\", line 355, in raw_decode\njson.decoder.JSONDecodeError: Expecting value: line 1 column 1 (char 0)\n"]

Pasglop

You have to replace path/to/etc with the actual path to the extracted file on your system.

edit I tried to reinstall and in fact I get this:

Can you please provide more informations: what’s your system exactly, when does the error happen.

My current config is OSX 10.14.6 Mojave, MacBook Pro mi-2012
Processor : 2.6ghz intel core i7
16 go DDR3 memory

So I download the file, and open it with the terminal, then press enter and have this result :
Capture d’écran 2020-11-01 à 18.01.40

Ok the executable is fine then, you’re not supposed to run it this way, but just to put path=/Users/cz/Desktop/osc-midi-osx in O-S-C’s midi config :slight_smile:

1 Like

Bonsoir Jean-Emmanuel,

J’ai extrait dans le dossier comme indiqué sur ma capture d’écran.

image

le fichier est bien exécutable pour l’utilisateur.
image

Mais erreur.

image

Il te manque la fin du chemin vers le fichier, tu n’as indiqué que le chemin vers le dossier qui le contient.

yep ! ça marche donc sous Ubuntu 18.04.

image

path=path/to/osc-midi-you-extracted/osc-midi-linux serait peut-être mieux alors dans ton premier post.

Avant dans cette ligne, j’avais un truc du genre ``foo:1,2`, il faut le mettre où désormais ? A la suite ?

1 Like

c’est bon j’ai retrouvé il faut mettre des espaces

image

J’essaierai sous windows 10 très prochainement sur des postes vierges.
a+

ok work fine :
path=/Users/cz/Desktop/osc-midi-osx virtual_midi:0,0

I’m taking the liberty to ping all active users, In case some would be interested in helping with the tests. @trust_level_1

1 Like

Hi @jean-emmanuel i gave this a shot on Windows x64 2004 seems to work. (wasn’t sure first if C: is needed after path -> it was not needed). Everything works like expected.

I’ll give this a go tomorrow and feed back.

Having just spent the last few hours re-adding all my devices to the midi config this would be a welcome addition!