Python-rtmidi not found (or wrong version) (running with python 3.7.0) Error

Hey everyone,

I'm trying to set up my OSC controller on a new pc running Windows 10 Professional and I am getting this error...


I didn't think I had to install Python but I have regardless. I'm just wondering how to get rid of it?
I've seen a few posts on this site with people that have experienced this and just wondering how to fix it. I'm considering reinstalling Windows as a drastic measure :joy:

Many thanks


1 Like

I confirm python is not needed if you use a recent version downloaded from this site. The most common cause for this type of issue on windows is the antivirus removing the midi binary file as it may be seen as (false positive) virus. Also make sure there's no path= option in your midi config.

1 Like

Is there a fix to this issue? Having the same problem running OSC off a secondary PC. Turning off Antivirus/Firewalls hasn't helped.

If the midi binary has been removed (there should be a message about it in the terminal if it's not found), turning off the antivirus will not restore it you'll need to redownload o-s-c.

Removed and re downloaded but the error message is still there.

Which error message exactly ? (make sure to check the whole log)

I get this error trying to view midi devices on a new PC. I'd hoped that rtpMIDI would've been an available MIDI port.

Could you please post the list of files found in open-stage-control-1.15.6-win32-x64/resources/app/server/ ?

1 Like

How does this look?

I suspect there's some compatibility issue with the midi bridge binary, I made a new build that should print more infos when failing (or that might also work if we're lucky), can you download osc-midi-windows.exe from here and replace that file in the server folder ?

1 Like

Done, no change to the error message unfortunately.

Ok, getting closer... could you please run open stage control with the attached file loaded in the custom-module option and tell me what's printed in the console when the server start ?
debug-mod.js (224 Bytes)

Thanks, could you please replace attached file in the same folder, restart the launcher and click "list midi devices" in the menu. You should see some extra debugging lines that should help me...
open-stage-control-server.js (2.2 MB)

Same error.

Did you quit and restart the app ? There are some extra messages that should appear, if they don't it means it's not the new file that's running.

hello there,

i don't know if it can help you or not but i met no issue on windows 10 pro using the windows (64 bits) version

And if i use your debug files, here is what i get.

I did. I tried it again this morning and get the same error as above.

Thanks Greenman. Is there anything Windows specific that needs to be installed outside of O-S-C?