Python-rtmidi not found (or wrong version) (running with python 3.7.0) Error

Done, no change to the error message unfortunately.

Ok, getting closer... could you please run open stage control with the attached file loaded in the custom-module option and tell me what's printed in the console when the server start ?
debug-mod.js (224 Bytes)

Thanks, could you please replace attached file in the same folder, restart the launcher and click "list midi devices" in the menu. You should see some extra debugging lines that should help me...
open-stage-control-server.js (2.2 MB)

Same error.

Did you quit and restart the app ? There are some extra messages that should appear, if they don't it means it's not the new file that's running.

hello there,

i don't know if it can help you or not but i met no issue on windows 10 pro using the windows (64 bits) version

And if i use your debug files, here is what i get.

I did. I tried it again this morning and get the same error as above.

Thanks Greenman. Is there anything Windows specific that needs to be installed outside of O-S-C?

Scratch that. The shortcut I was using to load OSC was linking to a different download folder. I sorted that issue and now get this.

you can use loopmidi on win10 and create a loopmidi port that will be listed then into O-S-C

I don't know rtpMidi but i installed rtpMidi and created a session and i can see it into OSC

Can you send a screenshot of your rtpmidi window ?

Ok cool it seems the new build works then, I'll include it in next release.

@jean-emmanuel for me there was no issue using https://github.com/jean-emmanuel/open-stage-control/releases/download/v1.15.6/open-stage-control-1.15.6-win32-x64.zip

la preuve

Thanks for your help with this, I really appreciate it. I'm getting closer.

If I power everything down and start up OSC I see rtpMIDI recognized as an available port. However when I start the server OSC disappears as an option.


s

Hum. Before listing the midi devices clear the console and check that rtpmidi is well in action.
Then tell us

1 Like

Here you go. Clearing the console and scanning for midi devices sees the rtpMIDI session and once the server is started another scan shows it missing.


1 Like

Are you able to connect to the rtpmidi ports with another software once they are missing from o-s-c's list ?

I'm able to connect my midi keyboard to rtpmidi and can send midi data to Cubase on the Mac. The disappearing midi devices was intermittent but the new 1.15.7 seems to have solved that issue.

I'm still not able to select OSC in rtpmidi and transmit anything, the midimonitor doesn't show any activity triggered by OSC. However, when I use my midi keyboard over rtpmidi i'm able to see lots of midi data being sent from Cubase back to OSC. So i'm halfway there it seems, I just need to sort sending to Cubase on the Mac.

Also since we've seemed to change topic, should I create an rtpmidi thread or is this better for continuity?

It seems the open stage control part is ok, I can't help much with the rtpmidi part unfortunately, but I suggest you read this thread:

Will do. Thanks again for your help.