(FIXED) Python-rtmidi not found (Windows ARM)


I've moved from Windows Pro laptop to Raspberry Pi 4 B (Windows 10 ARM) to run Open Stage Control. I got a hard time getting stuff installed but I managed to get them all on the machine. However, even with the correct path to python, and having python-rtmidi installed (with Python 3.9), OSC refuses to acknowledge it. I'm running out of ideas to fix this : <

You may have multiple python versions installed (the log says 3.7.0), using the path parameter will help o-s-c using the right one.

1 Like

EDIT: same error with the exe specified.

Not sure that's worse, this means there's no file at provided path. Shouldn't it be "Python39.exe" by the way ?

1 Like

Indeed, that's not worse. When I correctly add the exe file name, it says the same previous error but this time with (Python 3.9.0) instead of 3.7.0.
Maybe Python ghosted my path choice and installed itself a sneaky version in the usual hidden folder? I'm going to check this right now.

You could try running this in a terminal

cd C:\path\to\python_folder
Python39.exe -m pip install python-rtmidi --upgrade

To make sure python-rtmidi is installed for this version of python.

Just in case, the official procedure is here (under "other systems")

I expected this, and yep:

Requirement already satisfied: python-rtmidi in c:/program files/python39/lib./site-packages (1.4.9).

Do you know if Python is looking at the global or --user-base packages as default? I'm digging there for now as Python seems to not taking care of the global side-packages when OSC tries to check MIDI ports list.

Got an unknown error here. Not sure what it means.

There is some progress. After checking what was failing with python-rtmidi with

python --version
python -c 'import rtmidi;print(rtmidi.version, rtmidi._rtmidi.file)'

I've been able to spot the issue. By installing vc_redist.x86.exe, it resolves the problem. But it's far from being fixed. Windows refuse to recognize any of the MIDI port. Both virtual and over USB.

I have to find a solution to fix that new, very boring, issue...

EDIT: There are some msi installer issues with rtpmidi (from Tobias). I've contacted the developer to see how I can make it work. Not sure it was a great idea to go for ARM after all :smiley:

Sorry I can't help more, I know it works fine on linux-arm but windows-arm I can't test.

No worries, you've done a lot for me already :slight_smile: I will keep this post updated if someone goes for the ARM adventure and needs a map.

By the way, what's the point of running o-s-c on a separate system ? Having perf issues ? Otherwise you could simple use a browser on the ARM and let the server run on the main system.

That's what I'm doing for now. But usually, I try to avoid any other software than the ones I use for writing music. More software means more reg entries, more services, so more processes... and at the end more possibilities to have a system crash. I got no blue screens for over a year now, and I'm pretty sure that's because of my way of doing things. My philosophy is like: they all work for my main machine, and not on my main machine.

Don't get me wrong, I'm not saying OSC is unstable, but you know. I try to not take the risk :smiley:

Sounds reasonable :slight_smile:

1 Like

Hey @Manaberry , just wondering why you went for windows on the raspberry pi instead of linux?

I've tried Linux (Ubuntu) but there was no compatible software to create the MIDI port and I got errors straight out of the box. So I went for something I was more familiar with.

Ah yes, you mean like running rtpMidi or something like that? Is there nothing like that for linux?

There is. It's a little paid software, similar to the one from Tobias (Windows). It was not compatible with the last version of Ubuntu sadly.

That's interesting that there is no other option. That saves me from going down the raspberry pi road, which I was considering. Thank you for the updates.

There are maybe solutions out there I didn't find. I went for Chrome OS at the end. It does the job pretty well and the Raspberry is not even warm. I just cannot run the OSC server on it.