MIDI package detection

I am trying to install midi functionality with OSC but am running into this problem.
Does either package need to be placed somewhere for OSC to detect rtMIDI?

There shouldn’t be any additional step, however your python-rtmidi version is unusual, can you run pip install python-rtimidi --upgrade to get the latest stable release and try again ?

Got it to detect, the way RTM needs to be installed is kinda funky, I’m planning on writing a short guide on Midi once i get everything figured out myself.
For now, I’m getting this error.

image

Can you list your midi ports to the console?

here
image

And what are your midi settings?
(e.g. --midi MIDIPORTNAME:INPUTPORT,OUTPUTPORT)

Your logs indicate a malformed target, you are supposed to define the widget’s target to "midi:NAME" where NAME is the name defined in the server’s midi option (see @GeneralMidi’s comment), not the actual port’s name from the port lists.

Got it to detect, the way RTM needs to be installed is kinda funky,

Did you have to navigate in a particular folder before installing the library to make it work ? It might be a typical windows problem I could mention in the docs if that’s the case.

I had no problems installing and I’m on Windows. Others have confirmed also it works with no problems. Perhaps follow this guide :

https://vi-control.net/community/threads/open-stage-control-tutorial-an-alternative-to-lemur-and-touchosc.72643/

Please note that this tutorial is not up to date, the Visual C++ build tools parts is not necessary anymore.

Yes sorry. I meant to say check the very last post on page 7

hello folks,

could someone help me out with the midi side of OSC(just an empty line when right clicking on Midi->list devices)?

Details:
WIN7, Fireface UCX Interface (Midi ports show up in Reaper, for example)

Python 3.7 is installed, pip is installed,
“pip install python-rtmidi” -> “requirement already satisfied”

when try to verify like written here:
https://spotlightkid.github.io/python-rtmidi/install-windows.html

"
python
import rtmidi
"
gives nothing back

i installed the visual c++ build tools 14…

Thank you in advance

klaus

Hi,
@GeneralMidi posted a link to a good tutorial for setting up open stage control on windows. Do you have both python 2 and 3 installed ? There might a confusion between them (ie. rtmidi midi installed for one, o-s-c calling the other

Hi jean, emmanuel,
got it, works like expected (i tried “-m” instead of “–m”) -> the problem was me…
First i thought there is just a right click needed to show the midi device list, maybe this should be grayed out, when “–m” is not typed in the midi field…
Noticed further that no whitespaces are allowed in the Midi Port name(on the brand new 0.48)…
-> Error Midi …

Thank you for the hard work, highly appreciated

Well actually that’s a bug, you shouldn’t need to write anything in the midi option field for the “midi device list” action to work. It was introduced in v0.47.2, a fix has been uploaded and will be included in next release.

EDIT: The v0.48.0 release has been patched and reuploaded.

On a side note neither -m nor --m are valid option tokens for the midi option (if it happens to workaround the bug, these are ignored in the end).

Noticed further that no whitespaces are allowed in the Midi Port name(on the brand new 0.48)…

That’s documented here : https://openstagecontrol.ammd.net/docs/midi/#setup

Hi Klaus.
I have the same issue!!! Device listing does not work.
Jean-Emmanuel told me v0.48.0 has been patched alfter release. So I downloaded a windows 64 bit version again (v0.48.0) again without any results. I would expect v0.48.0 becomes v0.48.1 after patching (?)

So you installed visual c++ buildtools 14. Did you device listing work after installing this package?

Thank you so much for helping me out.

RoWi

Hi, yes i installed the buildtools, afterwards jean emmanuel commented that it is not needed
do you have python 3 installed and verified ? do you have rtmidi installed ?
i suggest using the precompiled binary install method like described here
(https://spotlightkid.github.io/python-rtmidi/installation.html#pre-compiled-binaries)
and linked on the midi setup page…

Yes, but it happened a few hours after the initial release so I considered the hotpatch harmless.

I downloaded again and deinstalled previous v0.48.0.
Next Ininstalled new version v0.48.0.

Unfortantely it didn’t solve the issue.

No devices are displayed.

Greetz ,

RoWi