First time user: "ERROR: Midi: unknown output

Hello all!

I have utilized the instructions from the Mac instructions video, and I am getting the ERROR: Midi: unknown output error.

I defined a midi port in audio midi setup called “TestMidi”. Here is a screenshot of my settings:

I am pretty clueless, so I don’t really know how to explain my problem any better. Please help me out! Thanks.

Hi, there seem to be an issue with midi ports on Mac but I haven’t been able to figure what exactly triggers it. Could you please try the latest alpha release with the same settings ? If it doesn’t work, please export the server settings (menu > save as) and upload the config file here.

Apologies for not yet supplying J-E with a most detailed account of where I found my things broke down.

What I found was that the default naming of MacOS’ in-built pre-supplied virtual driver which is identified as “IAC Driver” within MacOS, wouldn’t work with O.Stage.C. until I renamed it in the actual Audio Midi Setup (Applications -> Utilities -> Audio Midi Setup). I renamed to simply “IAC” (in Audio Midi Setup) and after that, following the also correct way of Id declaring in O.Stage.C. then communication works.

The fact that O.Stage.C. allows us to declare an Id of our choice just with no spaces and thus no need for quotes does not affect this version of the problem. That guidance should be followed anyway and on top of (IE still make sure your Id naming in the server config follows the documentation guidance!) - so as well as having that understanding of using an Id in O.Stage.C. mac users also need at the system level to not have their devices be named with spaces in them.

I believe it’s entirely straightforward to replicate the error on MacOS by trying a configuration where the system’s name for the midi device has a space, vs when it doesn’t. If there are still problems once the device is renamed at system level, I would suggest there are other problems, and that this is still required. I haven’t proved this by way of checking additional systems, this is my anecdotal experience though.

(Once again J-E thanks for your immense project/gift! Without this culture and dedication we are all

so much poorer)

Hi Jean! Thanks for the prompt reply. I updated to the newest alpha release. The problem seems to persist; also, the format has changed so now I don’t really know how to configure anything. Is there a user manual or documentation somewhere I can read and follow?

[EDIT after the fact: Ignore this, or, read as you like, but as J-E points out to me below, your screenshot shows the listed TestMidi device looks fine, sorry]

Hi Aniruddh, QB here, did you read my post above? Perhaps it wasn’t obvious that I’m addressing your question. It’s posted because I had the very same problem. At the system level of MacOS I found you have to use a midi device that does not have a space in the name - please review my post from yesterday and the screen grab + signposting. Applications -> Utilities -> Audio Midi Setup , rename device so at system level it has no spaces in it, after which start back at Open Stage Control, and follow what you were doing before with the midi settings in Open Stage Control config screen.

If it doesn’t fix the problem I would suggest there is more than one problem, because as far as I have found this is necessary.


@QBWarmDays Thanks for your help. It seems however the midi port is already formatted this way, from what I can see in the screenshot.

@aniruddh_immaneni Many thing are changing in v1 (see the discussion), it is still in alpha but close to release now and the documentation is pretty much up to date. Feel free to downgrade to v0 though, the old documentation is still available here.

Back on topic, the issue is still puzzling me, something must be failing silently where it should at least print an error, I’ll be adding some debug messages in next alpha release to help pinpoint the culprit.

ah oops sorry … yes. i will be watching with interest then to see what this is. hope you both solve soon.

Could you reproduce the bug with alpha 17 while enabling the server’s debug option and paste the console’s output here ?

For what it’s worth, you can also create virtual ports directly from O-S-C instead of using IAC by typing TestMidi:virtual