[Solved] Cannot start headless without X-window forwarding

I was just trying to start O-S-C in --no-gui mode over an ssh connection, and It would not start:

tedrippert@bender:~$ open-stage-control --no-gui -l ~/Documents/jsonrpc/GxGUI.json -c ~/Documents/jsonrpc/gx-rpc2osc.js -p 8090 &

[1] 7840
tedrippert@bender:~ (open-stage-control:7840): Gtk-WARNING **: 20:30:33.726: cannot open display: ^C [1]+ Exit 1 open-stage-control --no-gui -l ~/Documents/jsonrpc/GxGUI.json -c ~/Documents/jsonrpc/gx-rpc2osc.js -p 8090 tedrippert@bender:~ open-stage-control -h

(open-stage-control:7923): Gtk-WARNING **: 20:31:22.700: cannot open display:
tedrippert@bender:~$ open-stage-control -v

(open-stage-control:7975): Gtk-WARNING **: 20:31:32.661: cannot open display:

All these commands work if I use ssh -Y to start x-11 forwarding, but then I can't logout of the server without O-S-C exiting. I'm using version 1.8.15. I even tried using screen, but same result. Running in Ubuntu 18.04.

I recommend following these instructions in your case.

The Lite Headless mode worked. Thank you again.