Server doesn't respond without a browser conected

I'm running v 1.8.9 on a RaspeberryPi4 using the "Running with Node" option. I am receiving some midi foot controller messages with PureData and sending OSC to OpenStageControl to trigger multiple osc messages back to Pd. This way I can save states in OpenStageControl, and not have to implement presets in 2 places (and keeps gui updated).

However, with no browser connected (or tablet sleeps), OpenStageControl does not respond to the messages sent to it. This worked in v0 but probably because I was using xvfb headless method. It doesn't look like this method is supported any more since you are not building ARM binaries.

Any suggestions?

Thanks in advance, keep up the good work.

Building from sources on RPI should work and let you use the xvfb trick (which works for you because it creates an invisible client window that connects to server).

Alternatively, I think running this alongside the server should do:
xvfb chromium_or_firefox

Thanks jean,

I had tried running chromium in xvfb before posting, but it threw a bunch of dbus errors. I'll try a lighter weight browser. If that doesn't work, I'll build from source.

Thanks again

Chromium & firefox have a native --headless flag now, it may be worth a try.

Thanks Jean,

I was able to get chromium running in xvfb (not sure what I did wrong the first time). I'll check out the --headless flag.

At some point I'll do a build from source anyway, just to compare resource usage. In any case, I'm good to go for now.

Another way to solve this would be to handle the state persistence yourself using a custom module, this way you wouldn't need a fake client to be opened. I added an example in the docs that should do the trick !

Cool! I'll check it out. Right now I've got plenty of available resources on the pi, so a couple extra processes is no big deal. But, if I add more FFT based effects I might need this.

Thanks again