Server not accessable via browser with v.1.16 but with v.0.48

Hello OSC-Community,

I am using and starting OSC on my Master-PC, OSC gets controlled by a touch screen at a LAN-Connected secondary PC.
When I start a Session-File in OSC 0.48.X and use for example Port 7500 I am able to remote access him via browser (opera, chrome) perfectly.
When I start a Session-File in the latest OSC and use for example Port 7500 I am NOT able to remote access him via the browser. "Website is not reachable" ERR_CONNECTION_TIMED_OUT.

If I test it back again with OSC 0.48. it's working. So, I have the same IP, same Port working in 0.48 but not working in 1.16.X - any ideas why?

I can't find the issue and it drives me crazy :smiley:

Thanks to everyone who wants to help.

All the best,

What's the server configuration exactly ? And the client browser version ?

Hello Jean-Emmanuel,

thanks for your reply.

Server settings following in this post.
Server feedback after start: Server started, app available at: /

Settings: send:, Port: 7500, midi: xy, theme: orange

When I try to connect via Chrome or Opera, he is replying with the time-out.

But when I start 0.48 with the same settings. It connects instantly.
BTW: When my browser is trying to connect to the IP and is failing, I can close 1.16.1 and start up 0.48. on my Master-PC and my browser is automatically connecting to OSC without a manual refresh on my Secondary-PC's.

So it seems to be nothing about networking, it has to be something with the 1.16.1. - Or just a strange mistake that I do in difference between 0.48 and 1.16.1.

All the best,

Edit: // Chrome is fresh installed on updated version 101.0.4951.54

Okay guys,

first things first - I found the problem!

I thought networking can't be the issue, because of the working 0.48 version - but I was wrong.

I don't know why, but after starting 1.16.1 I have allowed Windows everything for the firewall-settings via the windows defender dialog. After posting my last answer, I jumped into the windows defender firewall settings and checked for incoming rules.

From 6 saved rules, two rules were set to NOT ALLOWED. I have double-checked all entries and changed the two NOT ALLOWED entries to ALLOWED.

My browser automatically refreshed and detected the 1.16.1 server and connected instantly.

So sorry for my weird issue. I had that not in mind at all! Hopefully someone finds help in this thread, when he runs into same problems.

Thanks a lot,

1 Like

Glad to hear it's solved ! On a side note, writing in the send option will only make o-s-c send all widget messages directly to itself, I can't think of a good reason to do that.

Hello Jean-Emmanuel,

thanks for your tip. I don't really get the background yet, but I can explain how I work and maybe you can figure it out, if it makes sense or not.

I am using Cubase on my Master-PC and parallel, I am hosting the OSC-Server on the same machine.
If I used my touchscreen at the Master-PC, I wouldn't be in need to use the network but if you interact with the touchscreen the mouse-cursor is always jumping out of cubase or is focussing the touchscreen and brings it to the top.

In my first steps with OSC in 0.48. a long time ago, I've connected the touchscreen to my Secondary-PC, starting a browser, connecting to the server... So that the server is still on the same machine as cubase, but gets the touch signals and controls from the secondary machine remotely. When I'm not completely wrong, it worked in the past with this routine.

Did something change to 1.16. so that my "idea" is not longer working like that?

All the best,