Problems loading template in FireFox

Trying to load my template into Mozilla FireFox for Windows 10. Made sure to download the latest version (1.9.7) of Open Stage Control. Tried all the different URLs listed and none of them work. It may be a network issue--working on that. Just wondering if anyone else is having a similar problem? Happy to provide more details if anyone thinks they can help, but don't want to get too much into it unless this is a useful topic for others.


1 Like

Make sure you're using firefox version 75 or higher, and double check the url protocol (https vs http). The firewall may be an issue too.

1 Like

Thanks for the response. FireFox is running v88.1.2. Double-checked url protocol, not luck. I suppose the firewall could be an issue, but I had no problems with running Open Stage Control on this device until a few days ago. Had been operating my template on this device for a couple weeks, and then it just stopped working. Tried it in Chrome this morning too and had the same problem.

I'm beginning to think it's just a network issue, frankly! Nothing else seems to make sense at this point.

Sounds like a classical windows update story to me :smile:

1 Like

Finally been able to narrow down the issue to something with the studio network. I doubt there's anything that can be done to fix it other than replacing our network systems, but if anyone has any suggestions with dealing with network issues in Open Stage Control, I'm all ears!

On the system you're running the server on, click on the magnifying glass on the lower left corner of windows, type "firewall" and click on the Windows Defender Firewall icon. On the left panel click on Inbound Rules and then in the middle scroll down to open-stage-control.

If you've run multiple versions there will be an entry for every version. Usually the one at the top of the list is the newest. If you double click on it, it will bring up a Properties dialog box. On the bottom of the General tab make sure in the Action section you have "Allow the connection" selected.

If there is no Inbound Rule for open-stage-control then you need to create one.