OpenStage knobs struggle to update

Good Evening Dear Community,

This is my first post. Before I start complaining (I am french, what did you expect?), I wanted to thank you for all for the topics, the ideas you addressed, and the pristine resolutions delivered by Jean-Emmanuel - which I thank so much for the lovely technology he brings to the human kind - Chapeau, Bravo, La grande classe, de la part d'un compatriote développeur. All your content allowed me to create, after 3 weeks, an essential companion to my existing live music project based on Ableton Live.

However, (There I start complaining!), for some reason, my OpenStage knobs struggles to update when I control an Ableton Live device parameter from a physical MIDI controller. The physical MIDI encoder needs first to be released, before OpenStage updates the virtual knob value. As you can see on the video below (hope you can see that .mov short video):

Notes: Parameter control from the iPad to Ableton Live : Real Time. From Ableton Live to the iPad: Real Time. From the MIDI Keyboard to Ableton Live: Real Time. The OpenStage knob only struggles when I trigger one of the physical MIDI encoders, controlling first an Ableton Live device, replicating OSC to the iPad.

Any solution, any idea, to solve this annoying issue? Please? :slight_smile:

Thank you again. Cheers, Benoît

Hi ! You can enable the OSC server's debug option to check what it receives exactly, here I suspect its ableton that simply waits before sending the feedback for the parameter you're controlling. Just to be sure, you're not touching the knob on the iPad while moving the physical knob ?

Hi ! Yes, on the video above I just turned a physical encoder on my MIDI Keyboard without touching the iPad. The OSC button struggles at updating on all clients: iPad, and OpenStageControl Server (Mac).

What I do not understand, is that the parameter value ("Mix", in % for instance) updates continuously as you can see, whereas the knob does not. I turned the debug option on but there are hundreds of OSC coming in from Ableton, and it is hard to understand what happens.

For your information, I am using ClyphX Pro (maybe you know it) as a control surface to bind components and send / receive OSC messages to and from Ableton Live. Talk yesterday to Clécio (maybe you know him) who developed TOCA OSC based on OpenStageControl, and apparently he has the same issue on knobs or faders, but could not find the root cause. Note that I built my own project from scratch, so it is totally different from TOCA, from both an OpenStageControl and a ClyphX Pro perspective.

Not to mention that I would be more than happy not to have to test on TouchOSC ! :smiley: Of course, I'm happy to provide you any information anytime to solve this issue.

In between I tested on various MIDI keyboards from different brands, changed MIDI channel and port, and... I even tested with TouchOSC with a single encoder ! (Sorry for that :smiley: ) : Same result. The good news is that I will continue to use your wonderful application (I had no doubt about it). The bad news is that I will have to check with the ClyphX guys to try to understand what's happening.

Thank you Jean-Emmanuel for your assistance. Anyone on this forum, feel free to ping me if you have any ideas to solve this one. Take care, Benoît

I hadn't noticed the percentage was updating properly, is this widget supposed to receive the same information as the knob or are these two distinct controls/addresses ?

Hi Jean-Emmanuel and all,

Since I use both physical MIDI controller and virtual OpenStageControl knob to control the same parameter in Ableton Live, I need to use ClyphX Bindings to bind these two physical and virtual controllers at the same time. At the time of the previous video, I used 2 different OSC addresses, then I tried with only one but nothing improved. So I recreated the issue with a very simple project with one knob and an indicator text only.

OSC Knob: CC 1, 70, id: dev1_1, OSC address /dev1_1. Indicator text value: /dev1_1/value. Physical MIDI Encoder: CC 1, 70 as well. Both virtual and physical knobs are then binded by ClyphX Bindings under the same name: dev1_1. (The name of the binding also serves as an OSC address). As a result, I have only single OSC address (/dev1_1), mapped on the same MIDI channel and port (1, 70).

The result remains the same. On the video below, I show 3 different scenarios : 1- Moving the Ableton Live slider with the mouse with instant update at OSC 2- Moving the OSC knob with the mouse with instant update at Ableton Live 3- Turning the physical MIDI encoder: Ableton Live responds instantly, not the OpenStageControl knob. Indicator text value is fine though.

Once again, the issue is not related to OpenStageControl since I had a similar or even worse behaviour with TouchOSC !

As always, any ideas are welcome. In the mean time, I will try to clariify with the ClyphX crew.

Thanks again for your time, I appreciate.

Ok so the knob and the text indicator are using two different addresses, looks like a bug in ableton/clyphX then. However you could circumvent the issue by using the text indicator's script to update the knob, somewhat overkill but it should work.

You raised my attention. Which script are you referring to ?

The text widget's onValue property: writing something like this could do the trick:

// onValue is executed when the widget's value changes
// replace knob_id with the actual id of the knob widget
set('knob_id', value)
1 Like

I'll try tonight !

Same result, again and again. Whatever ideas or tricks I can imagine, the result remains always the same.

Do you see anything wrong or stupid here ? I'd love to be stupid !

Knob :

Text with value :

Merci :slight_smile:

Well you'd need to multiply the value to mach the knob's range but if it doesn't work I'm out of idea :slight_smile:

I tested that trick already :smiley:
I gave everything I had into that battle. Now my ClyphX friends have to solve that part.

Yes it is annoying to see a widget not updating the way I want it to be. There will be a solution somedays. For now let me thank you once again for the superb “Open Stage Control” you created, and for everything you brought into it. Way better than worldclass. Not to mention your support….

Big Up J-E :muscle:

Talk soon,

Solved it !!! :star_struck: :champagne: :partying_face:

Removed the /control and CC parameters in the OSC properties of the knob, removed the target, and replaced them with a single OSC address "/osc_knob/int" : Done ! :hugs:

I knew there was a translation issue between MIDI and OSC, but I was not aware that I can just get rid of the OSC knob MIDI CC properties thanks to ClyphX Pro. Actually ClyphX Pro already registers all MIDI properties of all binded OSC controls itself, so we can purely work with OSC messages and avoid mixing with MIDI in OpenStageControl.

Thanks again for your help !

1 Like