No osc on rapberry pi. Buster - Solved > active the Debug option

Bonjour,

Après installation à partir du dépôt :

pi@raspberrypi:~/audio/open-stage-control $ npm -v
6.14.5
pi@raspberrypi:~/audio/open-stage-control $ node -v
v13.14.0
pi@raspberrypi:~/audio/open-stage-control $ cat /etc/issue
Raspbian GNU/Linux 10 \n \l

pi@raspberrypi:~/audio/open-stage-control $ 

Quand j’envoie sur le port 7777

(INFO) Server started, app available at 
    http://127.0.0.1:9090
    http://192.168.0.6:9090
(ERROR, CLIENT) Uncaught TypeError: this.remoteControl.exists is not a function
    at receive (src/client/osc.js:44:31)
    at receiveOsc (src/client/ipc/callbacks.js:23:12)
    at require (src/client/ipc/index.js:65:16)
    at this._listeners[evt].slice (src/client/events/event-emitter.js:29:29)
    at Array.isArray (src/client/ipc/index.js:148:21)
    at onmessage (src/client/ipc/index.js:99:21)

Peux-tu me donner la ligne de lancement du serveur et ce que tu envoies sur le port 7777 ?

et depuis sonic pi

use_osc "localhost", 7777

live_loop :sending do
  osc "/test", 60
  sleep 1
end

je n’ai aucun widget de créer pour l’instant. Normalement je devrais voir les signaux osc arrivés non ?

Oui, si tu actives l’option debug. L’erreur apparaît côté client, tu utilises un autre navigateur pour accéder à l’interface ?

ah la blague :slight_smile:. Elle n’était pas activée tu t’en doutes.

donc cela marche bien 10 000 excuses.
Je te laisse apprécier si tu supprimes ce post.

Ok, pour l’erreur j’ai trouvé c’est juste que le chargement de l’application côté client n’était pas terminé quand le message est arrivé.

oui effectivement mon screen n’avait pas de rapport avec l’option Debug.