Error When Starting OSC

I am trying to run Open Stage Control using a single machine and LoopMidi
I have been following this tutorial.
Running Windows 10 64-bit
I am getting this error when I press ‘Start’:

A JavaScript error occurred in the main process: Uncaught Exception: Error: ValueError: invalid literal for int() with base 10: ‘INPUTPORT’ at PythonShell.parseError (C:\Program Files\Open Stage Control\open-stage-control-0.49.6-win32-x64\resources\app\server\node_modules\python-shell\index.js:260:1) at terminateIfNeeded (C:\Program Files\Open Stage Control\open-stage-control-0.49.6-win32-x64\resources\app\server\node_modules\python-shell\index.js:139:1) at ChildProcess. (C:\Program Files\Open Stage Control\open-stage-control-0.49.6-win32-x64\resources\app\server\node_modules\python-shell\index.js:131:1)
at ChildProcess.emit (event.js:203:13)
at Process.ChildProcess._handle.onexit (internal\child_process.js:272:12)
----- Python Traceback -----
File “C:\ProgramFiles\Open Stage Control\open-stage-control-0.49.6-win32-x64/resources\app\server\python\midi.py”, line 33 in in_port, out_port = [int(x) for x in ports.split(’,’)]
File “C:\Program Files\Open Stage Control\open-stage-control-0.49.6-win32-x64\resources\app\server\python\midi.py”, line 33, in in_port, out_port = [int(x) for x in ports.split(’,’)]

Any idea how to clear this? Have I done something wrong?

Hi and welcome to the forum! Please post a screenshot of your settings window.

Hi, it looks like your midi settings are not formatted properly, could you paste the content of your midi option here ?

Yes, I am using loopMIDI. I created a new Midi port called VIControl. In my Midi options I have put:
“–midi toVIControl:5,6”

You don’t need the --midi part, it’s only used to set options when launching from a terminal.

Also check that there is no invisible character at the end that could have been brought with a copy-paste.

This is what my settings look like now. I still have this:

Did you try to empty the field (ctrl+a then delete, or click on the “x” on the right) and to retype it without copy-pasting ?

winner winner… I needed to hit the x button and retype. No more errors… Thank you Jean! I am a noob but very excited to switch from lemur to this. I appreciate your help.

Cool, I’ll make these copy-pasting errors less likely to happen in the future.