The URL from open stage wont run in my Android phone

It runs fine in my ipad or iphone. In fact in runs in many browsers, not only Chrome.
Running it Android 9, 6gb memory, Chrome, Huawei Mate Pro 20
I wonder if other people have the same problems than me in Android or it’s a local problem. I followed some of the indications in suggestions message to solve it, but did not work.

Did you follow this guide ? https://support.google.com/chrome/answer/95669?co=GENIE.Platform%3DAndroid&hl=en

Note that no support will be provided for these browsers, even if it seem to work.

Yes, I tried but did not work. This could be a local problem and works for other people. I wanted to know if other people have the same problem or they run it fine.
About other browsers, I don’t really mind, I commented it as curiosity.
It works running Bluestack Android emulator. I mention ir only as a curiosity, to point it can work in Android, that I’m interested in running it in emulation…

I could not test on the exact same device but it works fine on a Galaxy S10 / Android 9.

Ok, thanks. It must be a problem of my device.

Have you tried to pu http:// explicitely in the URL?

are you sure you can ping and reach
o-s-c server from your android device?

Tried edge and it works, it seem to be a specific problem of my phone, but as long it works in edge is fine.