SOLVED: Default Fader Range?

I do like to set my default fader range from 0 to 7. But when I start the session the range jumps from 0 to 1. What i am doing wrong?

Here ist the session: (1.3 KB)

1 Like

It works as expected here, don't you have a 2nd client open that your session is syncing to ?

my setup is:
Apple Studio M1 with DAW & OSC >
Ethernet network >
Windos Touch-Computer

I never edit on my Windows Touch Computer. For this I open OSC on my Apple Computer with "no-gui" off. But every time I changed something, I save it and than has the Touch screen the same content.

What I see in the OSC Console is this

Does that mean 2 Sessions?

Try closing all clients before reloading your session, the fader's default value should apply normally.
(What you see in the console is just the result of a console.log() in some widget's script, it doesn't say much about other clients connected to the server.)

You are right. If I open only this, it gets the right defaults.
Except for the two text widgets, which of course haven't received any info yet because I used setVar in the range fader.
Bildschirmfoto 2023-04-15 um 15.07.52

Maybe I have to check my big session, where I did some copies of widgets, to have some backups.

Arg.... big mistake on my side. The old "range fader widget" had the same name and the values was from 0 to 1 there.

One little more question:
That both text widget have a value in it from the beginning, should I use the get command?

The default value setting doesn't trigger the onValue script, you could circument that using onCreate:

  // setTimeout is used here because the range widget
  // is created before the text widgets so we need to wait a little
  setVar('text_0','quantity', get(this)[0])
  setVar('text_1','quantity', get(this)[1])

Or by using the @{} syntax in the texts' value properties instead of using scripting and custom variables.

We are too fast.... :wink: Thank you very much