Buttons CSS not responding to touch

Hi,
Surface Pro here (Windows 10 64bit)

For example :host:active in button’s CSS does not respond to touch anymore.
I jumped from version 0.49.10 to v1.0.0.0-beta9 and everything worked before.
In version 0.49.10 I used “:host.active” (dot between selectors) but this does not work in version 1.0.0 anymore.

I don’t know if it’s a bug or due to the new features and settings.

If I set interaction to false in widget settings, then the CSS action of the button responds to touch but only in edit mode.

You can use the browser inspector to find out the right css class to use, .active has been renamed to .on.

If I set interaction to false in widget settings, then the CSS action of the button responds to touch but only in edit mode.

That’s what it’s for.

Thank you Jean-Emmanuel, “.on” selector seems to work as I wanted! :smiley:

I am sure I had tried it before posting and it didn’t work as excepted, probably due to frequent errors (silently reported in the console). If I keep getting consistent bugs I’ll report in the bug tracker.

Thanks again for the great work and this nice update.