Load a session with an OSC message?

Is it possible to load a session with an OSC message ?
(sending the path to the .json file)

I would love to be able to automatically load a session when f.e. I load a Max patch or an Ableton Live session…

thanks

Mathieu

Not currently, it could be added as a remote control command.

would be great.

please consider it as a FR :yum:

Consider it done :wink:

Great, it works fine and is definitly very convenient, thanks :grinning:

one small issue : once a session has been loaded with this method, if it is edited, the “save” (or ctrl +S) function from O-S-C window doesn’t work ("… could not save, path outside of remote-root")
Capture d'écran 2020-10-22 17.03.40

“Save as…” seems to work, but as the built in file browser is not very convenient, it’s not easy to browse to the file location…
Could this be fixed ?

Mathieu

OK, “export” is a bit easier because it uses windows explorer :slight_smile:
BTW : what’s the difference between “save as” and “export” ??

sending the message OSC /SESSION/SAVE

Save current session to path.json . If path.json is omitted, current session’s path is used.

returns the same error message : “… could not save, path outside of remote-root”
So it’s not a workaround to easily save the edited session :confused:

sending /SESSION/SAVE witt the full path to the file doesn’t work either
image

Did you set the remote-root option ? If so, the error message is self-explanatory: you can’t write to files located outside of this folder.

Ho ok, so defining for example my root Dropbox folder where I store all my different projects should do the trick.
Thanks

/SESSION/OPEN works fine in windows, … but in macOs I can only get an error message :

(DEBUG, OSC) In: {
address: ‘/SESSION/OPEN’,
args: ‘Macintosh HD:/Users/mathieuchamagne/Dropbox/OpenStageControl/mes-exemples/O-S-C_Max_examples.json’
} From: 127.0.0.1:62844

here is the message sent from Max :

/SESSION/OPEN “Macintosh HD:/Users/mathieuchamagne/Dropbox/OpenStageControl/mes-exemples/O-S-C_Max_examples.json”

I also tried with different path style :

/SESSION/OPEN “Macintosh HD:Users:mathieuchamagne:Dropbox:OpenStageControl:mes-exemples:O-S-C_Max_examples.json”

and

/SESSION/OPEN ~/Dropbox/OpenStageControl/mes-exemples/O-S-C_Max_examples.json

I always get the same error message in O-S-C

Am I missing something ?
Did you tried it in macOs ?
(yes, I’m 100% sure that my file path is valid :slight_smile:

Did you try with /Users/mathieuchamagne/Dropbox/OpenStageControl/mes-exemples/O-S-C_Max_examples.json ?

~/ is not recognized in this case yet, I’m adding it for next release.

Did you tried it in macOs ?

I only use gnu/linux, I can only rely on users for testing on other OSes.

great, this one works on Mac, thanks :pray:
It will do the job for me, but I think that a full path would be really more convenient (what would be the correct path if my file is on an external hard drive ? …)

cheers

M

Full paths on unix systems start with a /, I guess the true path to your external drive is somewhere in /Volumes/

I’m still having troubles trying to save a session file opened with /SESSION/OPEN
I’ve defined my dropbox folder as my remote-root folder.
On Mac it works fine, I can save the file with /SESSION/SAVE

but on windows it doesn’t work (still get the error message “… could not save file outside of remote-root”)

(on windows a UNIX style path doesn’t seem to work : sending /SESSION/OPEN /Users/Apertures/Dropbox/OpenStageControl/mes-exemples/O-S-C_Max_examples.json
returns :
image

Windows is not a unix system, did you try sending a valid windows path (ie replacing slashes “/” with backslashes “\”) ?

EDIT: nevermind, I didn’t see you were sending /SAVE with no argument, gotta investigate on this.

I’m pushing two changes in 1.5.4:

  • one that hopefully fixes the issue you have on windows
  • one that makes relative session/state paths resolved against the remote-root option

Everything seems to work fine now on both mac & windows.
great job, thanks !