Pressure / Force

That wasn't a question :wink:


Another attempt will be available in a few minutes here Releases ยท jean-emmanuel/open-stage-control ยท GitHub

thanks again for your efforts.
but still no.
no error message, but something has changed.. pressure seems to jump between values more erratically.
with 1.18.1 :

and now with 1.18.2beta0 :

something gets corrupted after opening a session with a canvas accessing pressure.
If I open another session with a canvas containing this kind of script

// onTouch

// store normalized coordinates
if (event.type == "start") {
    locals.x = event.offsetX / width
    locals.y = event.offsetY / height
    value[0] = "moveto"
    value[1] = locals.x
    value[2] = locals.y

} else {
    // when the pointer is moving, increment coordinates
    // because offsetX and offsetY may not be relevant
    // if the pointer hovers a different widgets
    value[0]= "lineto"
    locals.x += event.movementX / width
    locals.y += event.movementY / height
    value[1] = locals.x
    value[2] = locals.y

// update widget value and send
set("this", value)

I then get these errors :

(ERROR, CLIENT) TypeError: undefined is not an object (evaluating 'this.iosTouchCache[e.pointerId]=e')
at touchCb (src/client/widgets/pads/canvas.js:162:55)
at this._listeners[evt].slice (src/client/events/event-emitter.js:36:29)
at triggerWidgetEvent (src/client/events/drag.js:225:50)
at triggerWidgetEvent (src/client/events/drag.js:99:27)
at pointerMoveFilter (src/client/events/drag.js:123:32)
at event.touches[j].target.isSameNode (src/client/events/drag.js:195:26)
(ERROR, CLIENT) TypeError: undefined is not an object (evaluating 'this.iosTouchPolls[e.pointerId]')
at this.getProp (src/client/widgets/pads/canvas.js:170:25)

Another beta is on the way, the error should be fixed. Does the erratic changes still happen?

No more error in this one.
but still erratic changes, and still no script called on pressure update.

I wish I could be more helpful ...

Another beta is uploading, unfortunately I don't think I'll be able to make more tries if this one fails..

Thanks again
this time, everything works like in 1.17.0 :
no more erratic change on pressure, but still no script called on pressure update. :frowning:

1.18.3 finally solved this issue :star_struck:
Canvas onTouch script is now called when stylus pressure & tilt are updated.

Here is a session showing some basic features ; I hope it can be useful to someone :slight_smile:
canvas_iPad_stylus_example.json (14.1 KB)

Thanks Jean-Emmanuel for your efforts to support this feature :pray: