No MIDI activity in Cubase

I've set up a single button in OSC and set up the IAC Driver as a generic remote but Cubase isn't registering anything in the MIDI activity monitor. Is there another step that i'm missing?


What is your target set to in your widget?

And can you list your midi devices in the console and check the 0,0 is correct.

The target is set to midi:OSC. I renamed the IAC Driver to OSC as well in case that caused an issue. Here are my midi devices.

Screen Shot 2022-03-18 at 10.11.44 AM

On Mac and Linux you can create a virtual port directly from open stage control (without using IAC) by writing name:virtual instead of name:0,0, this should be less error prone.

Thanks Jean-Emmanuel, i've tried using a virtual port and changed everything accordingly but i'm still not seeing any midi activity in Cubase. Does this setup look correct?


Try swapping your midi in and midi out channels in cubase - it looks like you’ve got them back to front in the generic remote settings.


1 Like

Not an option i'm afraid.
Screen Shot 2022-03-18 at 3.40.04 PM

That’s really strange. Can you check your virtual port (if that’s possible) and also check your cubase midi settings in your device manager.

On the OSC side -

The listing of midi devices is relative to OSC so the ones listed in the midi out section are out from OSC so you’ve got a midi in Chanel there, so that should be out from OSC and then in to your remote device, in this case Cubase.

On the Cubase side -

So if you then go to cubase that device should be listed as a “midi in” device in your listings, and then should be there as a listing when you configure your midi in device for generic remote.

I’m on a PC so I don’t use the virtual port so not sure about that - is there something in there that you can configure?

1 Like

Thanks for your interest in helping out with this.

Everything is set up as it should be. I've previously had Lemur controlling Cubase through the generic remote so i'm familiar with the process, but I can't get OSC to register at all. I'm at a loss as this seems to be too basic of an issue to be addressed in tutorials. There isn't any reason I can see why this shouldn't be working.

The midi_in / midi_out config is correct.

Can you enable the server's debug option and check what open stage control actually sends ?

Sure thing.

Ok so the message appears to be sent, do you have another software you could use to receive the message on the virtual port ?

1 Like

None that i'm aware of. Should there be an intermediary program that allows Cubase to recognize incoming messages from OSC?

I downloaded MIDI Monitor and it registers messages coming from OSC.

Have you tried checking the midi learn box in the generic remote set up in cubase? Just to see how far the message is getting? Make the channel and controller wron in cubase, click midi learn and then send it the midi message and see if it corrects itself?

Also, change the value that the controller sends to more than 1 - send 127. I’ve found (crazy as it sounds) cubase sometimes doesn’t hear the really low values.

1 Like

No luck with either sadly.

I've tried to set up OSC to send midi to Pro Tools and can't register any incoming data there either which leads me to believe that something isn't configured properly in OSC. Are there any other fields that need to be filled in? Is my formatting correct in the fields I have filled in?

The fact that you managed to see the midi events coming from open stage control in MIDI Monitor shows that the sending end is fine, I'm afraid the problem appears to be on the receiving end, be it Cubase or Pro Tool.

It looks like you're correct, I opened Dorico and it does detect incoming midi data from OSC. The issue does seem to be with Cubase.

Can you please post the following screenshots?

Screenshot 1

(from "Audio MIDI Setup" app on your MAC)

Screenshot 2

(the osc property of a fader that should send midi messages to Cubase)

Screenshot 3

(the console of O-S-C launcher when you turn it on)

Also, what macOS and Cubase version are you on? I believe you use Cubase 11... What about the OS?