New html attribute title / javascript reload Version 1.6.0

The new update is really amazing, the html property is really nice to label knobs, etc.
What i don’t get is how the “title” Attribute is used / works here. I assumed when adding this to e.g. a H3 Tag a Tooltip will show up when touching the Tag, but this doesn’t seem to work here.

It is just a knob with the html tag:

<h3 style="color:red;text.align:center;" title="tooltip"> GAIN </h3>

And i also noticed that it doesn’t seem to matter which H* Tag or (even P ) Tag you use, the text size doesn’t change… ?

Further noticed that sometimes the oscOutfilter Function is not called everytime.

I could reproduce it:
change a html attrib of a knob, change javascript, change a knob, change javascript.

Just a (DEBUG,OSC)… shows up but no execution of javascript (custom module reloaded successfully).

Thanks!

1 Like

The title works like in a barebone html page: a tooltip appears when the mouse stays on it, I don’t think there is a native support on touch device for this. You can make a tooltip manually : https://www.w3schools.com/css/css_tooltip.asp

And i also noticed that it doesn’t seem to matter which H* Tag or (even P ) Tag you use, the text size doesn’t change…

Custom html is unstyled, it’s up to you to do it (note that you can apply general css rules by writing them in the root’s css or in a theme file.

.html h1 {font-size: 200%}
.html h2 {font-size: 150%}
/* etc */

Further noticed that sometimes the oscOutfilter Function is not called everytime.

I could not reproduce that, can you provide a module file and a minimal step-by-step reproduction process ?

openstagecontrol4reaper.js (7.4 KB) OpenStageControl4reaper_2.json (795.1 KB) osc_config_2_config.json (219 Bytes)

Here are the files, sorry for the mess in there, a lot needs to be done there :frowning:
I noticed it in the Kemper Tag:

How i reproduced it:

  1. change the size of Gain Volume knob -> save it
    2.) change a console.log message in the js file, save this (gain volume is sending out like it should)
    3.) change the size of Gain Volume Knob again -> save it
    4.) change a console.log Message in the js file, save it
    5.) now Gain Volume just sending out one line of (DEBUG,OSC) Message but no js got executed.
    (stop and start the server -> then it works again)

Further noticed that in the case of 5.) JS seems to be executed e.g. in the matrix “Props” property.

Thanks!

1 Like

Following these steps does not lead to the described behavior, the modified console.log messages is printed correctly. I don’t see how editing/saving the session can affect the custom module, could you simply try saving the custom module multiple times and see if it stops working at some point ?

Hi, it is reproduceable here when changing the js file several times(2x times saving).(just tried it with deleting / inserting blank lines).

I also got a filewatcher error (a simple if instructions deleting a comment line with //… -> deleting two lines of comments at the end of the if instructions works… :slight_smile: )

Can you copy-paste the error here ?

sorry , i deleted it … it just prints out the line before the comment stood with a filewatcher error:

   send(midi,...); 
   //comment1
   //comment2
}

i deleted comment1 and the i saved the file…
if i see this error again, i will copy it…

Thank you for sharing your patch, it helps me to understand a part of cloning elements.

Hi @jean-emmanuel still have to restart OSC after saving the custom module 2x times. maybe i should make a short video to demonstrate this? (I am on the newest Version). -> no execution of infilter / outfilter …

Thanks!

The error message would be more useful :slight_smile:

There is no error message…

I may have found the issue: it could be the system’s file cache in fault here, I’ll try to bypass it.

Thanks for the update to 1.7.2 @jean-emmanuel, unfortunatly it does not work here, same issue as before…

Could you copy the full console logs here please ? The video doesn’t help much unfortunately…

Will give it a try tomorrow. I noticed that not all of the log is displayed / cutoff in the (server) console. (I also couldn’t find any error message ).

Thank you for the efforts!

There’s a history size limit, disabling the debug option will reduce the number of messages.

OSC_error.txt (4.6 KB)

See the comments in hash tags -> when DEBUG is on no error is displayed, it is just visible when debug is off -> i have a few console.log in it…

Thanks, the error helps ! It seems the file is read before the writing operation is over (hence the randomish error), I’ve been able to reproduce a similar error using a big file. To be fixed !

Cool, yep the file is quite big, more to come, because i want control everything music related here with OSC (soundcard too), not sure how to shrink it down exactly at the moment… Thanks!