Modal trapped in panel

I had a modal for sends on fader, in the editor on the computer it opens fine but on the ipad it is trapped inside the panel i have it nested in.

I was using the pannel to organize the button and the name tag and clone it for all 8 sends but i just pulled them out of the panel to free the modal.

Any ideas?


First, test if ignoreTabs set to true helps within the modal properties.

Secondly, I'm guessing that it could be an unfortunate iOS issue. It is an issue with iOS that causes issues with menus/modals specifically.


Cool, will check thanks!!
The modals once worked in the early 0.x versions of open stage on ipad, looking forward to checking it out.


yeah, it seems nothing fixes the modal problem, but oh well, tabs are the new modals! haha

tried it on a couple browsers and checked template Moss made for bitwig and it is all the same problem. I dont really need modals inside of panels. can just lift them to the main the tab container.
then it works fine. just cant code it quite as clean but what evs.

thanks! what are u using open stage for?

1 Like

Tabs are a great alternative. If it's just modal's inside panels that are causing the bug, another long-winded solution that you could try is the following. Create a modal button outside the panel. Inside the panel, have a toggle button that when the value is on, it'll set(idForModal , value) the modal to on/off depending on the toggle button widget. This way, the modal works but just lives outside the panel.

I use OSC for several things. Mainly, my music / cubase needs. In addition, I use it for simple windows scripts, toggling settings on/off for applications, pretty much anything that I want to use a touch button for.


I made some tests on remote iPads and modals seem to work fine, I suspect you encountered the same issue as in this thread: Modal acting weird in iPhoneX and iPad - #2 by jean-emmanuel